Solución al Problema de VS 2005 y SQL Server 2008

Al querer trabajar sobre una base de datos SQL Server 2008 desde el Visual Studio 2005 SP1, en el diseñador de dataset, me salio un mensaje de error que decia: “Esta versión del servidor no es compatible. Debe tener instalado Microsoft SQL Server 2005 Beta 2 o posterior”. Buscando en internet encontre una actualización que Microsoft lanzó para solucionar este problema.

Según Microsoft

Esta actualización resuelve el siguiente error que aparece cuando intenta utilizar las herramientas de diseño de Microsoft Visual Studio 2005 Service Pack 1 para abrir una conexión de base de datos con Microsoft SQL Server 2008:

“No se admite esta versión del servidor. Sólo se admiten servidores hasta la versión Microsoft SQL Server 2005.”

Esta actualización trata este problema y habilita la siguiente funcionalidad de Visual Studio para SQL Server 2008:

  • El explorador de servidores se conecta correctamente a SQL Server 2008 y los objetos de base de datos, como procedimientos almacenados y datos de tabla, se pueden ver y editar. Tenga en cuenta que los esquemas de tabla no se pueden ver ni editar en esta versión.
  • Los proyectos SQL CLR diseñados para SQL Server 2008 se pueden crear e implementar en el servidor.
  • Las depuraciones T-SQL y SQL CLR están habilitadas para SQL Server 2008.
  • Las características de enlace de datos en proyectos de cliente y web están habilitadas.

Esta actualización no admite las siguientes características para SQL Server 2008:

  • Creación y edición de esquemas de tabla en el diseñador de tablas o en los diagramas de base de datos. Como solución alternativa puede utilizar la característica del diseñador de tablas de SQL Server Management Studio 2008 para editar esquemas de tabla en SQL Server 2008.

Bien, para aquellos que tienen el mismo problema aqui les dejo el enlace de descarga de la actualización:

http://www.microsoft.com/downloads/details.aspx?FamilyId=e1109aef-1aa2-408d-aa0f-9df094f993bf&displaylang=es